activating an older veson of CubaseLE on mac os 10.7.5

All about our Cubase LE and Cubase AI OEM bundle software.
Post Reply
drewster
New Member
Posts: 11
Joined: Wed Apr 15, 2020 12:34 pm
Contact:

activating an older veson of CubaseLE on mac os 10.7.5

Post by drewster »

hello im trying to install an older version of cubase on my mac (i cannot upgrdae my mac past 10.7.5 - its old). i can get cubase 7 downloaded but cannot activate it. the elincenser says upgrade when i upgrade it says not compatible with this software.
does anyone have any suggestions.

can i get cubase LE on an old mac?

thanks
Drew

Martin.Jirsak
Forum Elder
Posts: 25090
Joined: Sun Mar 20, 2011 3:52 pm
Contact:

Re: activating an older veson of CubaseLE on mac os 10.7.5

Post by Martin.Jirsak »

Martin Jirsak
How to show notes of the chord/scale only
Cubase Training

Cubase Pro (last officially supported version all the time)
macOS (last update)

Post Reply

Return to “Cubase LE and Cubase AI”

Who is online

Users browsing this forum: No registered users and 3 guests