Installation Cubase 7.5 and Catalina

For users of legacy Steinberg Cubase software
Post Reply
Camille
New Member
Posts: 1
Joined: Sat Jun 13, 2020 3:13 pm
Contact:

Installation Cubase 7.5 and Catalina

Post by Camille »

Hello everybody :)

I need your precious help because I installed Cubase 7.5 on my iMac 2 or 3 years ago and I noticed in recent days that I did not have the sounds normally provided by the software (Halion Sonic SE, Groove Agent ... ).
I then wanted to uninstall and reinstall Cubase 7.5 to see if I did not voluntarily desactivate the installation of Cubase 7.5 sound plugins (Halion Sonic SE, Groove Agent ...) ... but now that I can no longer manage to install the software! Here are the problems that I encounter and that I cannot solve:
At the time, when I purchased Cubase 7.5, it came with an installation CD, but I don't have a CD player on my iMac. So I went to the Steinberg site to find an installation file to download, I found this:
https://www.steinberg.net/index.php?id=14736&L=1
Once the file is downloaded: I cannot use "Start Center" to install the software because I am told that it is out of date, and when I try to update it I am told that it works in 32-bit and that Catalina no longer supports 32-bit programs.
I try to open the .pkg file but I am told: "You need at least Mac OS X 10.6.0 to install this software" and indeed, I am on Mac OS X 10.5.5 but when I go to settings, it tells me "Your Mac is up to date" and it can't find any new updates available ...
What should I do ?
Why would Cubase 7.5 be incompatible with Catalina since I managed to use it a few days ago? (without the sound plugins, of course)
How to explain that now he doesn't even want to settle down anymore?
Please tell me there is a solution :) :)

Thanks a lot for your consideration and your response.

Wishing you a good day

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 8 guests