MI4 on Win7 64

For users of legacy Steinberg hardware
Post Reply
Thes
New Member
Posts: 15
Joined: Fri Dec 17, 2010 10:23 am
Contact:

MI4 on Win7 64

Post by Thes » Sun Jan 30, 2011 5:05 pm

Hi all,

I'm the proud owner of a Steinberg MI4 audio interface and it has served me very well all these years. So much so, I've no need to change it. I do, however, notice the inexorable march of time and the dropping of support for older operating systems (for Cubase 6, in particular, to which I'd like to upgrade from Studio 5).

Now - I'd like to install Win7 64 bit, but was wondering if anyone had any experience using the MI4 on this OS? I currently use it with Vista 64 using the drivers that came out a while ago - I'm guessing that Win7's compatibility features will let me install the Vista 64 drivers and the MI4 should be OK, but its just speculation.

Any advice?

Much appreciated,
Thes.
Cubase Studio 5.5.2, Wavelab Elements 7, Vista 64, Steinberg MI4, Nord Stage 88
Recent releases

Bernard Focquet
Member
Posts: 221
Joined: Wed Dec 15, 2010 5:00 pm
Location: Belgium
Contact:

Re: MI4 on Win7 64

Post by Bernard Focquet » Wed Feb 02, 2011 9:29 am

Nuendo 8.x, Cubase Pro 9.x, Wavelab Pro 9.x
PCs Win7/Win10 x64, Sony DMX-R100, RME Digiface, TC Powercore, MCU Pro

Thes
New Member
Posts: 15
Joined: Fri Dec 17, 2010 10:23 am
Contact:

Re: MI4 on Win7 64

Post by Thes » Wed Feb 02, 2011 10:01 am

Ah! Why didn't that come up when I searched...

Never mind - and thanks for the link. I'm off to get Win 7, then.
Cubase Studio 5.5.2, Wavelab Elements 7, Vista 64, Steinberg MI4, Nord Stage 88
Recent releases

maratrona
New Member
Posts: 2
Joined: Sat Jul 02, 2011 5:48 pm
Contact:

Re: MI4 on Win7 64

Post by maratrona » Sat Jul 02, 2011 6:11 pm

Hello everyone,
i think i need an help, i´m a total newbie and a friend of mine gave me this audio stuff called Media interdace MI4.

Well i downloaded driver (i have windows 7 but everything seems to be ok) and i plugged in the USB, changed in control panel to S/PDIF (that´s all i have).

Everything works fine but all i have is this Steinberg MI 4 panel showing me all lines but no sound comes from. I´m trying to get audio from phones.

Do i need some more drivers/software?
Do i need something else?

I home someone can help me. Thx

Thes
New Member
Posts: 15
Joined: Fri Dec 17, 2010 10:23 am
Contact:

Re: MI4 on Win7 64

Post by Thes » Sat Jul 02, 2011 6:24 pm

Hey there Maratrona.

Can you tell us a little more about what you're doing? Can you see the MI4 in Cubase when setting up VST connections? Or in Wavelab?

One thing about the MI4 in Vista and Win 7 that I've noticed is that it doesn't appear in your general WIndows mixer (accessible from the volume icon in the system tray), but its available to audio applications via the ASIO etc. This is a good thing!

Hopefully we can work it out.
Cheers,
Thes
Cubase Studio 5.5.2, Wavelab Elements 7, Vista 64, Steinberg MI4, Nord Stage 88
Recent releases

Seoman303
New Member
Posts: 9
Joined: Mon Jan 10, 2011 10:01 am
Contact:

Re: MI4 on Win7 64

Post by Seoman303 » Wed Dec 28, 2011 9:40 pm

Hello,

I don't know, if anyone is still interested, but I found a solution for the Windows 7 problem. After switching to Win7 64, I was able to use the device as default audio-device in Windows without any additional installation, but I wanted to use the ASIO-drivers through.

So I downloaded the 64Bit-driver for Vista and suddenly the device was not available as Windows audio-device any more.

The problem could be solved by the following steps:
- uninstalling all drivers
- executing the installer using the vista compatibility-mode (I've used Vista without any SP)

I hope, I could help.

Cheers

Gentlewaters
New Member
Posts: 1
Joined: Wed Jan 25, 2012 7:17 am
Contact:

Re: MI4 on Win7 64

Post by Gentlewaters » Wed Jan 25, 2012 7:22 am

How I installed the MI4 under Windows 7
After having to build a new system I ran into problems with the MI4. With a due respect I tried the route that Seoman303 suggested with a few modifications to the approach. It goes as follows:
----------------------------------------
First of all I installed the [ASIO4ALL_2_10 driver]
- http://www.steinberg.net/forum/viewtopi ... 25&t=10051 -
ASIO driver installed OK.
----------------------------------------
Tried to install drivers for the MI4 from CD, installation failed.
I then ran the MI4_setup in window compatibility mode for win 98.
Path to fallow:
Right click on the 'MI4_setup' icon, under 'compatibility' select [Windows 98/ Windows Me],
Put a check mark in all the boxes under 'Settings'.
Clicked on the 'MI4_setup' icon to execute and it installed
----------------------------------------
Loaded Cubase - Setup icon on CD - Cubase SL2 saw the MI4.
Loaded [Update_Cubase_SL.2.2.0.39]
- http://www.steinberg.net/en/support/uns ... _sl_2.html -
Cubase OK
The MI4 was still AWOL
----------------------------------------
Checked the Device Manager in computer properties
The Hardware driver did not install.................
Downloaded [MI4_2.8.14_Vista_64bit_only] driver for XP und Vista
- http://www.steinberg.net/en/support/uns ... 4_mi4.html -
Then Ran the [MI4_2.8.14_Vista_64bit_only] driver for XP und Vista, in normal mode and it installed OK.
----------------------------------------
Did a system reboot and Checked the Device Manager, hardware was ok, although midi was now amuck
Again to the Device Manager and under the USB controllers opened the 'Steinberg MI4 2.8.14' properties'
Path to fallow: [properties- driver- update driver- Browse my computer]
I manually installed midi drivers from [c:\Windows\usb-audio.deMI4USB].
----------------------------------------
Everything seems to be alright, no faults in Device Manager... time will tell. So if someone has problems with the MI4 that are not solve as suggested by Seoman303 then this may give a second path to resolution.
Respectfully:
Gentlewaters

George700DL
New Member
Posts: 2
Joined: Sat Feb 04, 2012 9:03 pm
Contact:

Re: MI4 on Win7 64

Post by George700DL » Sat Feb 04, 2012 9:08 pm

@Gentlewaters:

Thanks for the tips! I have the MI4 + old, old version of cubase (forgot which, I haven't used it in years). Your tips allowed me to set up the MI4 under Windows 7 64-bit. I plan on just using Audacity for home recording/mastering.

2 questions:

1. Using your steps, are you running the MI4 at 64 bits or 32?

2. I noticed on the MI4 panel that the "USB to Host" is showing 16-bit @ 44.1kHz. How can I set this up to 24-bit and a higher frequency?

Thanks.
George

George700DL
New Member
Posts: 2
Joined: Sat Feb 04, 2012 9:03 pm
Contact:

Re: MI4 on Win7 64

Post by George700DL » Mon Feb 06, 2012 5:57 pm

Nevermind, the resolution is configurable via ASIO setup...

Davec4567
New Member
Posts: 1
Joined: Wed Oct 15, 2014 1:16 pm
Contact:

Re: MI4 on Win7 64

Post by Davec4567 » Wed Oct 15, 2014 3:59 pm

Ive just migrated from XP to Windows 7 - 32 bit , does the above only apply to 64 bit?
I get MI4 installed although the setup stopped with 'This operating System is not supported'.
However it completed with a 'set up correctly' message and Windows 7 popped up with driver software intalled ok
Everything does seem to work ok and an MI4 icon appears at the bottom right but when clicked the MI4 panel does not appear. So I am stuck with line input and can get MI4 set up as monitor/default speaker. The mic/guitar jack on the front works ok in cubase taking precedence over line input as normal.
The trick from the above solution seems to be installing MI4 in a compatibility mode but I'm not sure how to do this
Any ideas?

Just a quick update - I right clicked on the MI4 setup icon on the disc and found the compatibility mode under properties but it made no difference

And a final goodbye - OK the MI4 is installed Ok but the Cubase doesnt recognise the MI4/dongle but when the MI4 is installed incorrectly (say without compatibility mode) the cubase can see MI4 but I cant get the MI4 panel. So goodbye cubase and hello the free version of presonus studio one.

http://www.steinberg.net/forums/posting ... 0&p=392744#

JSchick
New Member
Posts: 1
Joined: Wed Aug 05, 2015 11:34 am
Contact:

Re: MI4 on Win7 64

Post by JSchick » Wed Aug 05, 2015 1:17 pm

I had simular problems!

I am just running a Windows 7 (64bit) PC with Cubase 5.5.3.
First I refreshed the firmware of my MI4 with the MI4_Firmware_1.0.6 from the Steinberg-Portal.
I tried to install MI4 with the newest MI4 Version MI4_2.8.14_Vista 64bit also downloaded from the Steinberg-Portal.
The installation seemed to be successfull, but in Cubase MI4 was not reachable. Wether MIDI MI4IN nor MI4OUT.

Then I looked in "Systemeinstellungen in System and Gerätemanager" and I saw that MI4 Audio was a not proper installed. Only in USB-Controller Steinberg MI4 2.8.14 was successful installed.

So I tried to install the driver manually, but it failed.
So I searched for MI4AUDIO.INF in the Windows folder and renamed it to MI4 AUDIO.INF (its really a blank between MI4 and AUDIO. Just a small bug in the setup-routine).
Now I installed the driver directly in "Gerätemanager" and it worked perfectly!

I had to activate The MI4 ports in the ASIO (ASIO Direct Sound Full Duplex Setup) and it worked properly in Cubase 5.5.3!

Post Reply

Return to “Legacy Steinberg Hardware”

Who is online

Users browsing this forum: No registered users and 0 guests