Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

For users of legacy Steinberg Cubase software
erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Fri Mar 25, 2011 8:06 pm

Any experiencies after the upgrade to OSX 10.6.7?

I don't reach to use HALionOne in a new empty project (as an instrument track) after the upgrade to OSX 10.6.7. Cubase crashes immediately when loading it.
Actually I had to go back to cubase 5.5.1 because of a problem with presets in 5.5.2.

Can anyone confirm this or is it a single system glitch?
Last edited by erdwandler on Mon Apr 04, 2011 5:22 pm, edited 2 times in total.
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

Guest

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by Guest » Sat Mar 26, 2011 1:57 am

What if you re-install Halion? You can do it from the disc.

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by erdwandler » Sat Mar 26, 2011 3:47 pm

on the dvd i had there is the upgrade to Halion 1.1. I reinstalled it but the same behaviour. Cubase crashes in the moment I use/load a halion one instrument...

(btw: I recently reinstalled cubase 5 from scratch (first c5 then 5.5.1 upgrade) as mentioned because of other problems I had I kept to 5.5.1.
see cross-reference http://www.steinberg.net/forum/viewtopi ... =20&t=5771
may be worth a shot to try to upgrade again to 5.5.2 but am not sure if that helps...)
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by erdwandler » Sun Mar 27, 2011 3:46 pm

Anyone a clou or experience on this one?

!!! I even noticed that after the osx 10.6.7. Cubase AI4, SX3 & 4.5.2 crash all during startup!!!
and all seem to crash at the same point

Code: Select all

0   libSystem.B.dylib             	0x96710156 __kill + 10
1   libSystem.B.dylib             	0x96710148 kill$UNIX2003 + 32
2   libSystem.B.dylib             	0x967a2899 raise + 26
3   libSystem.B.dylib             	0x967b89b8 abort + 93
4   libstdc++.6.dylib             	0x973e2fda __gnu_cxx::__verbose_terminate_handler() + 433
5   libstdc++.6.dylib             	0x973e117a __cxxabiv1::__terminate(void (*)()) + 10
6   libstdc++.6.dylib             	0x973e11ba __cxxabiv1::__unexpected(void (*)()) + 0
7   libstdc++.6.dylib             	0x973e12b8 __gxx_exception_cleanup(_Unwind_Reason_Code, _Unwind_Exception*) + 0
8   libFontParser.dylib           	0x9842e67b TcmapEncodingTable::GetSubtable(unsigned short, unsigned short, unsigned short, unsigned short*) + 591
9   libFontParser.dylib           	0x9842e406 TcmapEncodingTable::TcmapEncodingTable(TSFNTFont const&, unsigned short, unsigned short, unsigned short) + 170
10  libFontParser.dylib           	0x9843929e TTrueTypeResourceFont::GetQDEncoding(unsigned short, unsigned short, unsigned short, unsigned short*) const + 60
11  libFontParser.dylib           	0x98439221 TTrueTypeResourceFont::GetNFNTInfo(TNFNTFontInfo&) const + 475
12  libTrueTypeScaler.dylib       	0x97f564ef CreateScalerFontBlock(fsg_SplineKey*, memoryContext*) + 2028
13  libTrueTypeScaler.dylib       	0x97f69a79 AssureScalerFontBlock(fsg_SplineKey*, memoryContext*, fontBlockCacheNode*&) + 48
14  libTrueTypeScaler.dylib       	0x97f55bef AssureStrikeBlocks(fsg_SplineKey*, memoryContext*, cacheStrike*, TStrikeDescription const*) + 82
15  libTrueTypeScaler.dylib       	0x97f5536b TTGetStrikeSpecs + 184
16  ...ple.ApplicationServices.ATS	0x9236bdea HandleOFAScalerMessage + 1348
17  ...ple.ApplicationServices.ATS	0x9236b83a SendStrikeMessage + 162
18  ...ple.ApplicationServices.ATS	0x9236eddc _eOFAGetStrikeSpecs + 471
19  ...ple.ApplicationServices.ATS	0x923696a7 _eGetGlyphVectorIndex + 994
20  ...ple.ApplicationServices.ATS	0x92368b4f OldGlyphsCacheStrike(TStrike*, void (*)(StrikeSpecs const*, void const*), void*) + 136
21  ...ple.ApplicationServices.ATS	0x9236879d _eGCGetStrikeMetrics + 65
22  ...ple.ApplicationServices.ATS	0x92367443 _eATSFontGetHorizontalMetrics + 173
[color=#FF0000]23  ...ple.ApplicationServices.ATS	0x9236737e ATSFontGetHorizontalMetrics + 76[/color]
24  com.steinberg.cubase          	0x00b15b74 start + 11611984
25  com.steinberg.cubase          	0x00c41ee6 MpexSetProperty(long, long double, unsigned long, void*) + 1203014
26  com.steinberg.cubase          	0x00c42092 MpexSetProperty(long, long double, unsigned long, void*) + 1203442
27  com.steinberg.cubase          	0x00c42112 MpexSetProperty(long, long double, unsigned long, void*) + 1203570

!!! the HALion one plugin crashes in cubase 5.5.1 also here:

Code: Select all

0   libSystem.B.dylib             	0x96710156 __kill + 10
1   libSystem.B.dylib             	0x96710148 kill$UNIX2003 + 32
2   libSystem.B.dylib             	0x967a2899 raise + 26
3   libSystem.B.dylib             	0x967b89b8 abort + 93
4   libstdc++.6.dylib             	0x973e2fda __gnu_cxx::__verbose_terminate_handler() + 433
5   libstdc++.6.dylib             	0x973e117a __cxxabiv1::__terminate(void (*)()) + 10
6   libstdc++.6.dylib             	0x973e11ba __cxxabiv1::__unexpected(void (*)()) + 0
7   libstdc++.6.dylib             	0x973e12b8 __gxx_exception_cleanup(_Unwind_Reason_Code, _Unwind_Exception*) + 0
8   libFontParser.dylib           	0x9842e67b TcmapEncodingTable::GetSubtable(unsigned short, unsigned short, unsigned short, unsigned short*) + 591
9   libFontParser.dylib           	0x9842e406 TcmapEncodingTable::TcmapEncodingTable(TSFNTFont const&, unsigned short, unsigned short, unsigned short) + 170
10  libFontParser.dylib           	0x9843929e TTrueTypeResourceFont::GetQDEncoding(unsigned short, unsigned short, unsigned short, unsigned short*) const + 60
11  libFontParser.dylib           	0x98439221 TTrueTypeResourceFont::GetNFNTInfo(TNFNTFontInfo&) const + 475
12  libTrueTypeScaler.dylib       	0x97f564ef CreateScalerFontBlock(fsg_SplineKey*, memoryContext*) + 2028
13  libTrueTypeScaler.dylib       	0x97f69a79 AssureScalerFontBlock(fsg_SplineKey*, memoryContext*, fontBlockCacheNode*&) + 48
14  libTrueTypeScaler.dylib       	0x97f55bef AssureStrikeBlocks(fsg_SplineKey*, memoryContext*, cacheStrike*, TStrikeDescription const*) + 82
15  libTrueTypeScaler.dylib       	0x97f5536b TTGetStrikeSpecs + 184
16  ...ple.ApplicationServices.ATS	0x9236bdea HandleOFAScalerMessage + 1348
17  ...ple.ApplicationServices.ATS	0x9236b83a SendStrikeMessage + 162
18  ...ple.ApplicationServices.ATS	0x9236eddc _eOFAGetStrikeSpecs + 471
19  ...ple.ApplicationServices.ATS	0x923696a7 _eGetGlyphVectorIndex + 994
20  ...ple.ApplicationServices.ATS	0x92368b4f OldGlyphsCacheStrike(TStrike*, void (*)(StrikeSpecs const*, void const*), void*) + 136
21  ...ple.ApplicationServices.ATS	0x9236879d _eGCGetStrikeMetrics + 65
22  ...ple.ApplicationServices.ATS	0x92367443 _eATSFontGetHorizontalMetrics + 173
[color=#FF0000]23  ...ple.ApplicationServices.ATS	0x9236737e ATSFontGetHorizontalMetrics + 76[/color]
24  com.steinberg.HALionOne       	0x25ad568e VSTPluginMain + 1177560
25  com.steinberg.HALionOne       	0x25ad75c0 VSTPluginMain + 1185546
26  com.steinberg.HALionOne       	0x25ad776c VSTPluginMain + 1185974
27  com.steinberg.HALionOne       	0x25ad77ec VSTPluginMain + 1186102
28  com.steinberg.HALionOne       	0x2597d41e 0x25800000 + 1561630
29  com.steinberg.HALionOne       	0x259b5c21 0x25800000 + 1793057
30  com.steinberg.HALionOne       	0x258065ca 0x25800000 + 26058
31  com.steinberg.HALionOne       	0x25804098 0x25800000 + 16536
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by erdwandler » Sun Mar 27, 2011 11:12 pm

OK, made a very very interesting experience!

I opened Cubase 5.5.1 under a new accont where no prefs of C5 were ever stored:
HALion plugin gets blacklisted there automatically.

At the other hand, Cubase SX3, AI4 & 4 crash immediately during startup too...

seems to me that OSX 10.6.7 is the trouble cause... anyone else experienced something similar? (well apparently not until now, as thee would be more posts... ;-) )
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

The Writer
New Member
Posts: 3
Joined: Sat Apr 02, 2011 3:14 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by The Writer » Sat Apr 02, 2011 9:57 pm

Same here, CB 4.5.1 crashes upon opening, in fact it doesn't even open. I get and immediate crash report. CB 5.5.3 on the other hand will open, BUT I'm unable to use Halion One (it's on the Blacklist, along with Surround Pan). Interestingly enough, I went back in time and copied the Blacklist of CB 4.5.1 from about 3 weeks ago because there was nothing on it, then swapped it with CB 5.5.3's Blacklist. I then start'd CB 5.5.3 and it ran it's usual routine until it got to Halion One, it crash'd at that point. So It may be more than just the OS update.
Attachments

[The extension txt has been deactivated and can no longer be displayed.]

MacBookPro 10.6.7/ 2.6GHzCore2Duo/ 4Gg Ram/ CB 553/ LP 9/ Rsn 5/ MR816csx/ Motif Rack ES/ PlugIns/ Motu Midi Express XT/ CME UF8/ Ox 8 v2/ TrgrFngr/ Roland Super JX10/ Glyph's/ KRK v6 ...

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by vic_france » Mon Apr 04, 2011 1:01 pm

I've just updated my main system disk to OS X 10.6.7, and I can confirm the crash on launch with Cubase 4.5.2 and earlier. (I've always like to keep old versions of Cubase on my machine.. never know when/if it might come in useful ;) )
I wouldn't have been surprised if those earlier versions were no longer compatible with OS X Lion (10.7), but it does seem a little strange with just a 10.6 incremental update.
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by vic_france » Mon Apr 04, 2011 1:04 pm

I can also confirm that HalionOne crashes upon instantiation with OS X 10.6.7
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Mon Apr 04, 2011 5:29 pm

hmmm... I hope Steinberg or Apple are aware of that, because that's quite an annoying situation...
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: OSX 10.6.7, CUbase 5.5.1 & HALion One (crash)

Post by vic_france » Mon Apr 11, 2011 3:59 pm

erdwandler wrote:OK, made a very very interesting experience!

I opened Cubase 5.5.1 under a new accont where no prefs of C5 were ever stored:
HALion plugin gets blacklisted there automatically.

At the other hand, Cubase SX3, AI4 & 4 crash immediately during startup too...

seems to me that OSX 10.6.7 is the trouble cause... anyone else experienced something similar? (well apparently not until now, as thee would be more posts... ;-) )
Even more interesting...
I too have just tried on a different User Account( that I keep specifically for testing purposes). There are no "haxies" or other 3rd-party "add-ons" in it..

Everything is working o.k. there!

So it isn't OS X 1.6.7 that is at fault.. has to be a conflict with something else in my main User Account (but, so far, no luck in tracking it down).

@Erdwandler,
How "clean" is that other account? (maybe we can identify a common 3rd-party installation?)
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Mon Apr 11, 2011 7:05 pm

hmmmmm...
interesting point...
I could make a new userAccount and check if there the problem appears, but I just rechecked and 3rd party plugs are all installed in base-library and though accessible for AllUsers...
so that won't help too much...

P.S: by 3rd party add-ons you refere to VST-specifical plugs & add-ons, right?
I just could manually/temporarily remove the 3rd party VST's and see what happens... But would take a while, taking into account that a fallback is also probably needed...

at the other hand, the crash-report of C4 didn't indicate any plugin involved but only cubase:

Code: Select all

22  ...ple.ApplicationServices.ATS   0x92367443 _eATSFontGetHorizontalMetrics + 173
[color=#FF0000]23  ...ple.ApplicationServices.ATS   0x9236737e ATSFontGetHorizontalMetrics + 76[/color]
24  com.steinberg.cubase             0x00b15b74 start + 11611984
25  com.steinberg.cubase             0x00c41ee6 MpexSetProperty(long, long double, unsigned long, void*) + 1203014
26  com.steinberg.cubase             0x00c42092 MpexSetProperty(long, long double, unsigned long, void*) + 1203442
Do you have a C4 crash-Report? perhaps we can therefrom compare & see what happens...
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Mon Apr 11, 2011 7:40 pm

No, it seems to be happening at a much more immediate level than VST plugins. The program doesn't even start to launch, it just quits immediately, and the log shows the crash at thread #00.
I also get the same crash if I launch HALion Symphonic Standalone, for example.
It is o.k. if I do a "Safe Boot", but, for example, deactivating all Preference Panes and Background applications doesn't make any difference. It is way beyond my competence to troubleshoot.
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Mon Apr 11, 2011 8:14 pm

vic_france wrote:The program doesn't even start to launch, it just quits immediately, and the log shows the crash at thread #00
...
It is way beyond my competence to troubleshoot.
That is my worry too, therefore I didn't even look further and reinstalled 10.6.6...

Hope that Steinberg does something about that if they reach to identify what the cause is. i have send several crash reports to apple with indications on what I did and hope they also get to Steinberg if they get enough crash reports... so that they're able to fix it...
It seems to me that it's kind of the Codebase which was used, a function which doesn't get supported or so. But I don't know OSX nor Cubase good enough to be able to tell where that could come from...

I really have no clue what could interfere, I'm kind of clueless in which direction I could try to troubleshoot this...
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Wed Apr 13, 2011 1:19 am

I don't know if the following is relevant in your case, but I've solved my OS X 10.6.7 issues here!.. It was.. a font! (in my User Account.. haven't tracked down which one yet, simply deactivated the font folder for now, and will put the fonts back, a few at a time until I find the culprit).
HALionOne and HALion Symphonic worked immediately.
As for Cubase 4.5.2, it started to launch o.k. (as opposed to quitting immediately, as previously), but did eventually crash before completing instantiation (I think I saw the same mpex errors as in your crashlog). So I just trashed Preferences, rebooted, and now Cubase 4.5.2 is fine too.
You may also have a non-compatible VST plugin.
But, did I read that you have already rolled back to OS X 10.6.6 anyways?
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Wed Apr 13, 2011 3:26 pm

Hi Vic,

That's more than great news!!! and amazing ones... thx for sharing your findings! The 4.5.2 pref trashing wouldn't be a problem at all...

Yes, you read correctly. I rolled back to 10.6.6 because I can't stand a system not working. Besides it was my only system to make music and had to export some tracks whith HALion one, so I needed to go back immediately...

But if it's only a font, that makes the upgrade more interesting again...
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Wed Apr 13, 2011 4:08 pm

Btw, did you try on a new User Account, before rolling back? (that would have been the easiest way to verify).
Do you have a spare disk (or partition), to try out OS X 10.6.7 again?

Anyways, so far (touch wood!) all is still fine here :).
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Wed Apr 13, 2011 5:39 pm

yes, i actually tried it on a useraccount, where no Cubase had the same problem...
hmmm. at the moment not, but would be perhaps a good occasion to do so... I could tra to install it on an external disk if that works (I'll check that)...

My desk is made with glass, but I'll touch the wood-floor ;-) good news. Hope that we/you find the specific font which causes that... (was a good Idea to dig there...)

Cheers!
I'll keep you informed if i find something too...
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Wed Apr 13, 2011 6:27 pm

It was a very old Cyrillic collection.. certainly migrated across from my old machine. Maybe a good time to do a bit of "spring cleaning" ;)
You should be fine with an external FireWire disk (either do a clean install, or use SuperDuper or Carbon Copy Cloner to clone from your main System disk).
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Wed Apr 13, 2011 7:25 pm

it weren't by occasion these fonts???
(they're actually very old and I never intentionally installed them... do you know by occasion, why they have a blue frame?)
Attachments
fonts.jpg
(57.07 KiB) Not downloaded yet
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Thu Apr 14, 2011 1:42 am

It is exactly those fonts! (remove them, then I'm 99% certain you'll be good to go in OS X 10.6.7 ;) ).
The blue means that, at some stage, they were assigned a (priority) "label". Can be changed either in the Finder's "Get Info" dialog, or via the Actions widget in the Finder window's Actions drop-down menu.

I never installed those fonts deliberately myself, but there's still a lot of "migrated" stuff on my machine, that I have never bothered to purge. As far as I have been able to ascertain, they originally got installed back in the pre Mac OS X days, as part of Apple's ClarisWorks .
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Fri Apr 15, 2011 5:55 pm

!!! that's a good remark!!!

Indeed my machine is aprox 3 years old and came with OSX10.5 pre-installed, so at some step between the fonts must have come in... and for a strange reason must have been assigned this priority level...
it's funny that the marking accords with the crash-cause... funny... but now as we have circled the potential cause I'll probably try the upgrade again this week-end
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Fri Apr 15, 2011 7:14 pm

(.. but don't shoot me if it still crashes! :o :D just kidding )
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Fri Apr 15, 2011 8:34 pm

nono, don't worry... (aehmm, just for curiosity: where do you live exactly? :lol: ) hahahaha :lol:
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

erdwandler
Junior Member
Posts: 125
Joined: Fri Jan 07, 2011 6:42 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by erdwandler » Mon Apr 18, 2011 12:01 am

Hi Vic,

I tested this issue again and found some more problematic fonts.
(white ones)
ProblematicFonts.gif
Problematic Fonts for Cubase SX3, Cubase 4 & HALion One in Cubase 5, together with OSX 10.6.7
(40.81 KiB) Not downloaded yet
I am not 100% sure about the yellow ones, but as they're also from this very old date (no idea how they got there, I never had an OSX in 1996) I also excluded them...
I'll make later a test to see if they're really problematic, but blue and white ones are involved...

THX vic for troubleshooting this into the right direction...

P.S: It might be that not all blue & white are involved. I excluded the fonts on a date basis as these differ seriously from the dates of other fonts.
------------------------------------
erdwandler
myspace/erdwandler
soundcloud/erwandler

Notebook: MacBook Pro 4,1, Intel Core 2 Duo (2.6 GHz), 4 GB RAM, 800 MHz Bus, OSX 10.6.7
Soundcard: MOTU UltraLite mk3 (Firewire)
Gear: Clavia Nord Wave, Clavia NordRack2, Access Virusb
Cubase 5.5.1, 4.5.2, SX3 & AI4

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Confirmed: OSX 10.6.7, Cubase 5.5.x & HALion One (crash)

Post by vic_france » Mon Apr 18, 2011 12:37 am

So, just to clarify..
Is Cubase now working o.k. with those fonts removed?

Here (where it is working o.k. now), in comparison with your list,
We already know that the "blue" ones are a no-no (so I have removed them here)
I have later versions of your three "yellow" ones.
Of the "white" ones, I have..
the same version of Chicago CE
and later versions of Courrier CE, Monotype Sorts, and Times OE Roman.suit.

If wou wish, PM me with your email address, and I'll send those later versions to you (although they are probably duplicates, anyways, of later bundled suitcases that are surely already on your machine. Have you used Apple's FontBook to check for duplicates?)
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 9 guests