Another problem when rendering to FLAC

All topics on WaveLab 8 and WaveLab Elements 8
User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Another problem when rendering to FLAC

Post by Pietzcker » Wed Oct 01, 2014 8:05 pm

Sorry to bother you all with another question...

I don't know if this is limited to FLAC, or if it has anything to do with the other problem I encountered (see here), but there is another thing I don't understand:

I have a 24bit/48kHz recording which I've loaded into an audio montage (Wavelab 8.5.10). I haven't used any resampling plugins (just Maximizer and Peak Master), but when I render a FLAC output file (using the flac hq preset), the resulting FLAC file has a 44.1 kHz sampling rate. Why?

In the File Format dialog of the Render window, Sample rate is set to "Like input source" (German version "Wie Eingangsquelle"), and the Audio montage properties are set to Stereo, CD compatible/Sample rate 48 000 Hz, as well.

Where are the 44.1 kHz coming from?

Cheers,
Tim
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
MrSoundman
Senior Member
Posts: 2178
Joined: Fri Dec 24, 2010 3:27 am
Contact:

Re: Another problem when rendering to FLAC

Post by MrSoundman » Wed Oct 01, 2014 9:53 pm

I cannot reproduce that here, with a 48kHz file in the Wave Editor, when I render using the "FLAC hq" factory preset I get a 48kHz FLAC file.
Windows 10 Pro | Cubase Pro 9.5.50 | WaveLab 9.5.50 | HALion 6.2.20 | Groove Agent 4.2.40 | Midex 3/Midex 8 | x64 only

User avatar
Justin P
Senior Member
Posts: 2320
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Another problem when rendering to FLAC

Post by Justin P » Thu Oct 02, 2014 1:54 am

I can't reproduce here either. I don't do much FLAC work but when I render a FLAC file from a 48k montage with the settings shown in the attached screen shot, the resulting FLAC render is 24-bit/48k when I open it in the edit side of Wavelab to analyze it.

Picture of settings attached:
Attachments
FLAC_48k.png
(142.17 KiB) Not downloaded yet
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.4
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.4

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Thu Oct 02, 2014 11:49 am

I'm using the same settings...:
02-10-_2014_12-41-23.png
Settings
Setting
(337.21 KiB) Not downloaded yet
Result (as displayed both by Wavelab and dbPowerAmp):
02-10-_2014_12-46-31.png
Result
(53.4 KiB) Not downloaded yet
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

PG
Moderator
Posts: 6578
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Another problem when rendering to FLAC

Post by PG » Thu Oct 02, 2014 12:15 pm

Thanks for your nice pictures. But I can't reproduce the problem (I am checking the flac sample rate from WaveLab).
I would need to see all the options in the Render dialog, the part of the render dialog which is hidden on your 1st picture.

Philippe
Philippe

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Thu Oct 02, 2014 12:28 pm

Here it is:
02-10-_2014_13-27-38.png
Render dialog
(59.54 KiB) Not downloaded yet
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

PG
Moderator
Posts: 6578
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Another problem when rendering to FLAC

Post by PG » Thu Oct 02, 2014 2:02 pm

Using exactly your settings, I can't reproduce the problem.
I note a curious detail, though: when the option "Open resulting file" is unchecked (as on your dialog), the option "Bypass Master Section on resulting file" should be disabled (by WaveLab). This is not the case on your picture. Are you really using WaveLab 8.5.10?
Philippe

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Thu Oct 02, 2014 4:07 pm

Yes, it's Version 8.5.10 (build 857) - 64 bit

As for the un-disabled checkbox, I've captured a quick screencast to show what's happening on my PC: The checkbox always comes up enabled when the dialog is opened; only if I uncheck "Open resulting file", the other checkbox gets grayed out.
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Thu Oct 02, 2014 8:51 pm

To illustrate my problem, I've created another quick screencast - is there any other option I might have overlooked that will cause the sampling rate to change?

(By the way, the preview quality of Dropbox' MP4 video files is rather bad; if you can't see what's happening, please download the file - that will be in full resolution)
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Tue Oct 07, 2014 6:21 am

Any ideas on this issue? I'm definitely not making this up... :cry:
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

bob99
Senior Member
Posts: 2437
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Another problem when rendering to FLAC

Post by bob99 » Tue Oct 07, 2014 9:04 am

Have you tried removing all insert plugins? Or forcing 48KHz (not match input stream). And then opening the result file in Wavelab. This only happens with FLAC, not Wav?
Windows 7, Windows XP

User avatar
Justin P
Senior Member
Posts: 2320
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Another problem when rendering to FLAC

Post by Justin P » Tue Oct 07, 2014 1:40 pm

In the edit mode of Wavelab, does it also show that the rendered FLAC file is 44.1k instead of 48k, or just your dB Poweramp?

Maybe you could upload a zip of your montage and one or two songs and I could open and do a test render here to see if something is corrupted in your montage or settings somehow.

It's very strange.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.4
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.4

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Tue Oct 07, 2014 3:40 pm

Thanks for taking the time to reply. I'm not sure what you mean by "removing insert plugins", can you clarify?

Also, yes, the 44.1 is shown in Wavelab as well (look at the second screencast I posted), not just in Windows/dbPoweramp.

I'll try to reproduce this with a smaller montage file/audio file and see if I can post this.
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

bob99
Senior Member
Posts: 2437
Joined: Fri Jan 07, 2011 2:49 am
Contact:

Re: Another problem when rendering to FLAC

Post by bob99 » Tue Oct 07, 2014 6:55 pm

I meant remove all of the plugins in the Master Section shown in your picture. Instead of disabling or turning them off, remove all of them (the Maximizer, Peak Master, Crystal Resampler, MBiT dithering, and the Encoder Checker). Remove them.

Also instead of "Samplerate Wie Eingangsquelle" in the Audiodateiformat, make it "Samplerate 48 KHz".

Also try rendering the same thing to WAV instead of FLAC. Does this also happen to your result WAV if you render to WAV, or only if you render to FLAC? (Does the result WAV come out 48K or 44.1K?)
Last edited by bob99 on Tue Oct 07, 2014 7:45 pm, edited 1 time in total.
Windows 7, Windows XP

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Tue Oct 07, 2014 7:34 pm

OK, I've reproduced the problem with a small file. I've uploaded the WAV file (containing just audience noise for a few seconds), the .mon file I created and the resulting FLAC file to here.

The steps I took:
  • Open the WAV file in Wavelab's file editor.
  • Choose File - Export - Create audio montage from current file
  • Check to see that it's 48 kHz
  • Choose Render with default options (flac hq)
  • The new FLAC file opens in Wavelab and is at 44.1 kHz
Again, I made a screencast to show what I did. Can you reproduce this?

I also tried the same thing after having deleted all the plugins from the effects queue as well as from Dithering and Post Processing - no change in outcome.

Interestingly, though, I also get 44.1 kHz when I choose WAV 24 bit as output - so it's not limited to FLAC.

And when I manually set the output sampling rate to 48000, I do get 48000 (after a stern warning that Wavelab recommends the "Use input stream" setting), but that's not the point (I think). The point is why Wavelab appears to think that the input stream is 44.1k when it's clearly 48k...
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Justin P
Senior Member
Posts: 2320
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Another problem when rendering to FLAC

Post by Justin P » Tue Oct 07, 2014 7:46 pm

I used your source WAV file and test montage and I still can't reproduce the problem. I watched the screencast but I do not know the language that you are using in Wavelab so I can't comment on all your render settings.

Opening your montage and rendering a level 8 Flac file with my render settings attached in the screenshot produces a 48k Flac file. Also, doing your workflow of opening the 48k WAV in the edit mode, and creating a montage from the current file, and then rendering to level 8 Flac file also produces a 48k Flac file.

Here is a link to both of the rendered Flac files I made from the methods described above:

https://www.dropbox.com/s/zi8r7ier3w29x ... 1.zip?dl=0

File A is direct from your montage, file B is making my own new montage from the source file in the edit mode.
Attachments
JP_Flac_01.png
(526.13 KiB) Not downloaded yet
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.4
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.4

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Tue Oct 07, 2014 8:11 pm

Thanks for going to all that trouble. I'm quite sure that I haven't changed any of the render settings, but of course it's unfortunate that I can only generate a German screencast...

I'm increasingly starting to think that there must be some other setting outside of all this workflow that somehow affects the result (since it happens for FLAC and WAV), but I have no idea where to look...
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Justin P
Senior Member
Posts: 2320
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Another problem when rendering to FLAC

Post by Justin P » Tue Oct 07, 2014 8:32 pm

Do you have another computer you can test on? Or another sound card output you can switch to for a test?

For the render settings, it sounds like you have it correct but you want to have the sample rate "match input stream".

When you open my Flac files in Wavelab editor mode, did they show as 48k?

Maybe see if you can use my Flac 8 preset to render from:
Attachments
FLAC Level 8.dat.zip
(492 Bytes) Downloaded 159 times
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.4
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.4

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

User avatar
MrSoundman
Senior Member
Posts: 2178
Joined: Fri Dec 24, 2010 3:27 am
Contact:

Re: Another problem when rendering to FLAC

Post by MrSoundman » Tue Oct 07, 2014 9:12 pm

I have also tried the test.zip and cannot reproduce the problem. I've also checked (using MediaInfo) that the same version of libFLAC was used (1.3.0) and the only difference is the bitrate. One strange thing though is that the test.flac in the zip is 956157 bytes in size, but the one I render is only 903588, and the reason I find that strange is that one would imagine that, all things being equal, a file with a higher bitrate would be larger.

So I just listened to both the test.flac and the original test.wav, and the decoded flac (which should be lossless, i.e. no different to the original, by definition!) is louder than the wav. You have something somewhere in your render chain that is causing a difference; the reason your flac is larger is because there's more high-frequency energy to be encoded (due to the increased level). Find out what's causing that increase and you'll find what's changing your samplerate.
Windows 10 Pro | Cubase Pro 9.5.50 | WaveLab 9.5.50 | HALion 6.2.20 | Groove Agent 4.2.40 | Midex 3/Midex 8 | x64 only

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Tue Oct 07, 2014 9:30 pm

@MrSoundMan: During the rendering of the FLAC file in my ZIP file, the Maximizer and Peak Master plugins were active, which is why the FLAC is louder than the WAV.

However, the problem persists even if I delete those plugins from the chain. So that's not it, unfortunately.
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Tue Oct 07, 2014 9:44 pm

@JPerkinski: Your FLAC files show as 48k in Wavelab editor mode. I don't have a different sound card or PC to try this on.

I also used your preset and still got a 44.1 kHz output file...
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Justin P
Senior Member
Posts: 2320
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Another problem when rendering to FLAC

Post by Justin P » Tue Oct 07, 2014 11:01 pm

Well, this sounds like a very strange bug or deep problem. Unfortunately, I don't know Windows or German well enough to help any more.

For entertainment, have you tried using the Crystal Resampler to successfully make a 96k FLAC file, or even setting the Resampler to 48k, even though you are at 48k?
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.4
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.4

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Wed Oct 08, 2014 6:13 am

@Jperkinski: The plot thickens. I have just enabled Crystal resampler, setting it to 96 KHz.

When I now click on Render, the dialog has changed spontaneously: In the File format dropdown, it now reads "Flac / Stereo / 96 000 Hz / Pegel: 8" (which is a mistranslation, by the way - "Level" doesn't translate to "Pegel" here, because it has nothing to do with "sound intensity" but with compression efficiency; "Stufe" would be correct, but that's incidental).

When I open the File format dialog, it looks the same as before except that "Channels" has been set to "Stereo"; "Sample Rate" is still set to use the input stream settings.

When I do the render now, the output file is still in 44.1 kHz! WTF?

I've got to go to work now, so I can't test the other cases right now, but I thought you might find this interesting.

Cheers,
Tim
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
Pietzcker
Junior Member
Posts: 168
Joined: Mon Sep 29, 2014 2:17 pm
Contact:

Re: Another problem when rendering to FLAC

Post by Pietzcker » Wed Oct 08, 2014 11:22 am

To add to the strangeness: Rendering definitely takes a lot longer when setting Crystal resampler to, say, 384 kHz than when setting it to 48 kHz or turning it off - but the resulting files are nearly identical in size, and they sound identical, but they are entirely different when doing a byte-by-byte comparison (probably the result of resampling from 384 kHz to 44.1 looks different than when it's done from 48 to 44.1?)...
Windows 10, Dorico Pro 2, NotePerformer 3, Pianoteq 6, Wavelab Pro 9.5

User avatar
MrSoundman
Senior Member
Posts: 2178
Joined: Fri Dec 24, 2010 3:27 am
Contact:

Re: Another problem when rendering to FLAC

Post by MrSoundman » Wed Oct 08, 2014 9:25 pm

One thing you could try is resetting WaveLab to the defaults .... quit WL, go to %APPDATA%\Steinberg and rename the folder "WaveLab 8.5" temporarily; when you restart WL, it will create a new folder there with the original name. Do your tests again.

To get back to your old settings, just delete the newly-created folder and rename the old one back to the original.
Windows 10 Pro | Cubase Pro 9.5.50 | WaveLab 9.5.50 | HALion 6.2.20 | Groove Agent 4.2.40 | Midex 3/Midex 8 | x64 only

Post Reply

Return to “WaveLab 8 | WaveLab Elements 8”

Who is online

Users browsing this forum: No registered users and 0 guests