Recording MIDI = everything is in advance

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Recording MIDI = everything is in advance

Post by h3kt0 »

Title says it all. When I playback MIDI recorded notes, they are all playing in advance from the grid.

I tried ticking the "timestamp" boxes in the Devices menu and checked/upodatd all drivers from my keyboard and soundcard, all fine but didn't solve the issue.

Is there anyone experiencing this or can anyone suggest a workaround? Because it's really annoying having to select all the notes from EACH take and move them a bit forward everytime I record...

Thank you!

C8 Pro
Win7 64 Ultimate
RME FireFace400
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by LarsErik »

I've also got this problem.

This is a screenshot from a midi recording (running in 100 bpm) where I'm trying to play as accurate as possible. Sounded good when I recorded but as you can see it didn't turn out so good.

Image

I've tried all the settings I could come up with like constrain delay compensation, asio guard, midi timestamp and what not but it makes no difference.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

Absolutely, I had the exact same problem.
I was wondering if it was me but it obviously wasn't, I'm glad I'm not the only one having this issue.
And yes, and you mentioned the zero latency option doesn't help.
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
Hedshaker
Member
Posts: 274
Joined: Thu Sep 12, 2013 4:54 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by Hedshaker »

I also get this issue, have for a long time. In fact, I can't remember getting relative MIDI accuracy since pre MIDI Audio days when Cubase, Logic etc where designed to sequence external synths and samplers. Maybe it's got worse over the years as modern DAWs have become more bloated, dunno :?

Or maybe my playing has got poorer.....? But I have to edit everything after playing it even with auto quantize on.

I just live with it but if there's a way to improve the situation I'm all ears, and fingers :)
Asus P9X79 I7 - 4930K @340GHz, 16 GB Ram. Windows 10. EMU 1820m. Cubase Pro 10.##. UAD quad, UAD Solo PowerCore Element with Access Virus. AN1x, Dave Smith Mopho. Yamaha NS-10m studio Monitors.

https://soundcloud.com/dark-blue-man

characterstudios
Junior Member
Posts: 73
Joined: Thu Jan 06, 2011 9:30 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by characterstudios »

Noticed the same thing yesterday. MIDI data from my Cirklon (which is synced to Cubase with a SyncGen Pro) is 'recorded' early. Jitter is low, but data is recorded early. I need to check if this is related to Delay Compensation though, and if the amount of time the data is recorded earlier is consistent between takes.

Regards,

characterstudios

User avatar
Hedshaker
Member
Posts: 274
Joined: Thu Sep 12, 2013 4:54 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by Hedshaker »

Hedshaker wrote:I also get this issue, have for a long time. In fact, I can't remember getting relative MIDI accuracy since pre MIDI Audio days when Cubase, Logic etc where designed to sequence external synths and samplers. Maybe it's got worse over the years as modern DAWs have become more bloated, dunno :?

Or maybe my playing has got poorer.....? But I have to edit everything after playing it even with auto quantize on.

I just live with it but if there's a way to improve the situation I'm all ears, and fingers :)
Edit: Actually I just checked and found that auto quantize hasn't been on since Cubase 8. That should hopefully improve matters. They seem to have hidden the auto quantize button in CB 8
Asus P9X79 I7 - 4930K @340GHz, 16 GB Ram. Windows 10. EMU 1820m. Cubase Pro 10.##. UAD quad, UAD Solo PowerCore Element with Access Virus. AN1x, Dave Smith Mopho. Yamaha NS-10m studio Monitors.

https://soundcloud.com/dark-blue-man

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

Auto quantizing will have the same result as quantizing after the performance, which will result in inaccurate note snapping.
I never used auto quantizing as I don't want all the notes to be on the grid all the time, I usually just select the ones I want to quantize and do it.
But this is a different matter, we are talking about some kind of "negative latency" that makes all the notes playback in advance vs what we actually played while hearing the click/music/whatever .

It would be really nice to have someone from Steinberg replying and see if they acknowledged this issue or not.
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by LarsErik »

Well I sure didn't have this problem in Cubase 7 so I'm thinking there might be some setting that I've overlooked.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

characterstudios
Junior Member
Posts: 73
Joined: Thu Jan 06, 2011 9:30 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by characterstudios »

Yeah, auto-quantizing is not ideal. I use insane amounts of swing on the Cirklon, so auto-quantize would mess with that. Let's see if Steinberg responds to this, I did not have this in C7 either.

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by LarsErik »

Ok, so now my problem is gone. The thing that made the difference was that I went into the Midi Port Setup in the device setup and pressed the Reset button.

Time will tell if this really was the source of the problem but for now midi records just fine.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

Ok thank you, I might try that and let you know if it solves the problem !
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

characterstudios
Junior Member
Posts: 73
Joined: Thu Jan 06, 2011 9:30 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by characterstudios »

Yes thanks, will try that too!

User avatar
Hedshaker
Member
Posts: 274
Joined: Thu Sep 12, 2013 4:54 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by Hedshaker »

I like to get the notes as close as possible on grid to begin with and then add or program any groove element I want after. I rarely find any useful groove or swing in random and unexpected off grid notes, though it could happen I guess, in a serendipitous way.
Asus P9X79 I7 - 4930K @340GHz, 16 GB Ram. Windows 10. EMU 1820m. Cubase Pro 10.##. UAD quad, UAD Solo PowerCore Element with Access Virus. AN1x, Dave Smith Mopho. Yamaha NS-10m studio Monitors.

https://soundcloud.com/dark-blue-man

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

Ok I tried to reset the MIDI and it didn't work...did it work for you characterstudios ?
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by LarsErik »

h3kt0 wrote:Ok I tried to reset the MIDI and it didn't work...did it work for you characterstudios ?
Ok, but how about the record midi settings? Here's mine:

Image
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

All the same except I didn't have ASIO Latency Compensation Active by Default ticked...I tried ticking it and nothing changed.
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by LarsErik »

Ok, then I guess the only thing left to try (with this stuff anyways) is for you to reset your midi ports having the "ASIO Latency Compensation Active by Default" checked.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
silhouette
Senior Member
Posts: 1322
Joined: Fri Jan 14, 2011 12:45 am
Contact:

Re: Recording MIDI = everything is in advance

Post by silhouette »

You could try removing the ignoreportfilter file. Create a folder within and stick it in there so you don't lose it should you want to replace it.

Program files>Steinberg>midi port enabler

I seem to remember this having an effect in an earlier version. If it doesn't work it is easily replaced.
Intel core i7 5960X CPU 3.0 GHz 64bit 32 gig RAM - Windows 10 - AMD RadeonHD 7700 - RME Fireface UC - Cubase 10.5 - UAD Solo + Duo + Quad - Nektar Panorama P1 - Komplete 12 - All uhe - Adam AX7 + Adam Sub 8 - BFD3 - Alchemy - PSP - FabFilter - Fender Telecaster- Wudtone Strat - Gibson L4, 335x2,330L,175 -Ibanez PM100 - Musicman Silhouette x 3 - Warwick Thumb Bass - Kemper Profiling Amp -https://soundcloud.com/silhouette-17

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

It's very subtle, I think I'll have to try with more recording tests but I think it works now :)

Thank you LarsErik !!
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by LarsErik »

h3kt0 wrote:It's very subtle, I think I'll have to try with more recording tests but I think it works now :)

Thank you LarsErik !!
You're welcome.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

erik.smeets
Junior Member
Posts: 116
Joined: Wed Aug 10, 2011 9:39 am
Contact:

Re: Recording MIDI = everything is in advance

Post by erik.smeets »

and how can I fix this on OSX?

User avatar
enjneer
Member
Posts: 839
Joined: Mon Feb 25, 2013 10:10 pm
Location: Ottawa
Contact:

Re: Recording MIDI = everything is in advance

Post by enjneer »

Disable ASIO Latency compensation on the MIDI Channel you're Recording into. Or, turn it on if it's off. This function actually moves the notes, trying to compensate for current latency.
http://dahlhousestudios.com
Mac Pro 2008 (3.1); 14G RAM; GeForce GT 120 512M
OSX 10.9
FireFace 800
UAD 2 Duo
Bryston 4B
Yamaha NS-10Ms
Presonus Central Station
Cubase 7; 7.5; 8 64-bit
Wavelab 7

Keith99
Member
Posts: 412
Joined: Sun Jan 23, 2011 11:16 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by Keith99 »

Just had this happen to me but when mixing down a beat designer insert, so not even from an external controller

OldFecker
Junior Member
Posts: 142
Joined: Tue Aug 06, 2013 9:03 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by OldFecker »

This has plagued Cubase since version SX3, but it was allegedly fixed in C7 with the inclusion of a new control on the MIDI track you are recording onto.

http://www.steinberg.net/forums/viewtop ... 46&t=17949

tl;dr (ie what's really going on)

When you record MIDI in a situation where the audio feedback of your playing has some latency in it (eg a VST synth), you as a musician naturally compensate by subconsciously playing slightly ahead. Trouble is, Cubase records the MIDI note event at the timecode where the key press was detected, and not where the monitored feedback sound hit your ears a short while later. So, it sounds fine during recording, but early during playback.

I'm still on C6.5, so I can't personally verify if they ever fixed it.

The workaround is to manually move all you MIDI to the right a few ticks after recording it.
Studio One 3.5.1 / Cubase 6.5.5 / UAD 2 Quad / Win 7 x64 / intel i7 920 4 x 3.8GHz

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Recording MIDI = everything is in advance

Post by h3kt0 »

The workaround is to manually move all you MIDI to the right a few ticks after recording it.
Lol, the whole point was to avoid having to do that :lol:
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

Post Reply

Return to “General”

Who is online

Users browsing this forum: ezbie and 1 guest