Audio Records Early... Midi is Fine

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
User avatar
Prock
Grand Senior Member
Posts: 3982
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Audio Records Early... Midi is Fine

Post by Prock »

OK...

I see many posts for midi somehow getting shifted early in relation to the click/timing. Luckily I don't have that issue but I do have an issue the looks the same as the midi issue but only on audio tracks. Over the years I've seen a few others who have asked about this but I don't see a fix for it. So, for me, the only fix I can do is basically the same as the early midi issue. Meaning I must either move the audio recordings slightly to the right to match the midi (which is on time) or move the midi sightly left to match the "earliness" (if that's a word) of the audio. The "fix" I use depends on the complexity of the project and which type of track would seem easier to move.

When I was able to open old projects in the version of Cubase they were created on I saw that this issue was not there in CB LE4 nor do I remember seeing it in the early CB 7 series. It is there in projects created in the later CB 7, 7.5 and 8 series.

I am recording all my audio thru a 2007 vintage PreSonus Firebox and I am using the latest (and last updated) driver that was released years ago for that interface (it is no loner supported by PreSonus).

My intentions are to purchase a new audio interface soon. Mostly because I want to get on board with Windows 10 when it is issued. Of course before upgrading to W10 I will wait until the software for my home studio (like CB) gets certified for it.

So, other than suggesting that I replace the old Firebox, I am wondering if there are any other suggestions that I might try. Really, the only things I have tried are to vary the audio driver values I list below. I've tried every combination available on the driver menus and I always end up using these as most things seems to work the best at these settings.

The driver is set follows:
Latency: 8.0 ms
Sample rate: 44.1 kHz
Clock source: Internal

Thanks a bunch folks ;)

Regards 8-)
PRock Studio

DAW: Cubase Pro 11, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

User avatar
ggc
Senior Member
Posts: 1434
Joined: Thu Feb 17, 2011 6:17 am

Re: Audio Records Early... Midi is Fine

Post by ggc »

I generally use free audio warp on every file...

But...

This did interest me in the past, so, here is a solution..maybe..

Do a loopback test..

Meaning,
-connect the output of your interface to the input
- play a short snappy transient rich sound on an audio track
-record that sound simultaneously in cubase
- see how many samples/milliseconds the recording is off by
- in prefs - vst audio system, adjust your record latency by this value

That will take care of your audio interface based recording latency..
If it is based on something else, idk...

Greets:)

Edit: how is it with asioguard turned off?

User avatar
Prock
Grand Senior Member
Posts: 3982
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Audio Records Early... Midi is Fine

Post by Prock »

ggc wrote:I generally use free audio warp on every file...

But...

This did interest me in the past, so, here is a solution..maybe..

Do a loopback test..

Meaning,
-connect the output of your interface to the input
- play a short snappy transient rich sound on an audio track
-record that sound simultaneously in cubase
- see how many samples/milliseconds the recording is off by
- in prefs - vst audio system, adjust your record latency by this value

That will take care of your audio interface based recording latency..
If it is based on something else, idk...

Greets:)

Edit: how is it with asioguard turned off?
Thanks....

Ill try the loopback test as you described and report back.

Also, no difference with asioguard on or off.

Regards. 8-)
PRock Studio

DAW: Cubase Pro 11, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

User avatar
h3kt0
Junior Member
Posts: 91
Joined: Fri May 27, 2011 6:08 pm
Contact:

Re: Audio Records Early... Midi is Fine

Post by h3kt0 »

I'm sorry for you OP but I'm glad to see that I'm not the only one facing this really weird issue.
I own an RME Fireface 400 and have the exact same problem.
The only workaround I found is to put the offset on the track to 20ms but it's really a pain when you are tracking 40+ vocal tracks, and it's just a bandaid solution for a bigger issue I can't seem to pinpoint the cause of.

I tried pretty mch everything to test this and the weirdest thing is that it doesn't occur all the time. On some project everything sounds on time, and in some others this early latency is there, wether I start a complete blank project or one of my templates.

If you find a solution please let me know : h3kt0@free.fr

Good luck ;)
Cubase Pro 9.0.41
Cubase Pro 10
Windows 10 Pro 64 bits
Intel i7 4770k 3.50Ghz - 24 Gb RAM
RME Fireface 400

User avatar
Prock
Grand Senior Member
Posts: 3982
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Audio Records Early... Midi is Fine

Post by Prock »

Prock wrote:
ggc wrote:I generally use free audio warp on every file...

But...

This did interest me in the past, so, here is a solution..maybe..

Do a loopback test..

Meaning,
-connect the output of your interface to the input
- play a short snappy transient rich sound on an audio track
-record that sound simultaneously in cubase
- see how many samples/milliseconds the recording is off by
- in prefs - vst audio system, adjust your record latency by this value

That will take care of your audio interface based recording latency..
If it is based on something else, idk...

Greets:)

Edit: how is it with asioguard turned off?
Thanks....

Ill try the loopback test as you described and report back.

Also, no difference with asioguard on or off.

Regards. 8-)
Well... I tried the loopback test as suggested but I was not able to find why the audio is early. :?

I recorded (2) guitar takes.

The 1st take was recorded to (2) tracks with asioguard "on". One track with VST Amplitube 3 connected (but not active). The other with "no vst".

The 2nd take was recorded to (2) tracks with asioguard "off". One track with VST Amplitube 3 connected (but not active). The other with "no vst".

The loopback recordings were done by connecting a guitar cable from my Firebox headphone out to the instrument 1 input jack.

Both of the 1st recorded tracks start 44ms early. Both loopbacks for these tracks start 43ms early.
Both of the 2nd recorded tracks start 42ms early. Both loopbacks for these tracks start 41ms early.

In this test project I also recorded some midi to an instrument track. The midi notes vary slightly but most are 3ms early to 1ms late.

So, the audio latency through my Firebox apparently is 1ms. Not much there to adjust. Right? Or am I missing things that can be adjusted? I'm much more concerned with the 44ms early start time.

Next I am going to try the other ASIO drivers listed in the VST Audio System. There is one named "ASIO DirectX Full Duplex Driver" and another named "Generic Low Latency ASIO Driver". I am currently using the "Firebox ASIO x64 Driver" that came with the PreSonus Firebox audio interface.

Regards 8-)
PRock Studio

DAW: Cubase Pro 11, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

User avatar
ggc
Senior Member
Posts: 1434
Joined: Thu Feb 17, 2011 6:17 am

Re: Audio Records Early... Midi is Fine

Post by ggc »

Try opening a new project, top left in the bar with quantise/transport etc- (directly under and between File&Edit above)
-"constrain delay compensation" and turn it off. - ( if it is not visible right click in an empty space and activate visibility)
See how that works for you..(with asioguard off)

User avatar
VinnieD
Member
Posts: 305
Joined: Sat Mar 09, 2013 8:56 am
Contact:

Re: Audio Records Early... Midi is Fine

Post by VinnieD »

Maybe your Audio is fine, just the MIDI late? ;)
Cubase Pro 11 - HALion 6/ HALionsonic 3 - NeoSoul Keys - Absolute VST+ - Kick2 - Groove Agent 5 - Korg Legacy M1 - Komplete Ult 12 - Sylenth1 - BlueII - SubBoomBass2 - TAL-U-NO-LX - Cable Guys bundle - Diva
Win 10 (64b) - 32GB RAM - i7 6 core - NVidia Geforce GTX1050
Focusrite Scarlet 18/8 Mk3 - Yamaha H8 - Komplete Kontrol S88 - Machine Mk3 - Korg MS20 (Full Size Kit) - Behringer TB-03
iPad Air 2 - Cubasis 2 - Cubase IC Pro - Nanologue

User avatar
ggc
Senior Member
Posts: 1434
Joined: Thu Feb 17, 2011 6:17 am

Re: Audio Records Early... Midi is Fine

Post by ggc »

Ok, really last post for me for today (no loose ends;))
VinnieD wrote:Maybe your Audio is fine, just the MIDI late? ;)
If thats the case- goto prefs - record- midi- tick asio latency compensation active by default and see if it helps..

User avatar
Prock
Grand Senior Member
Posts: 3982
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Audio Records Early... Midi is Fine

Post by Prock »

ggc wrote:Try opening a new project, top left in the bar with quantise/transport etc- (directly under and between File&Edit above)
-"constrain delay compensation" and turn it off. - ( if it is not visible right click in an empty space and activate visibility)
See how that works for you..(with asioguard off)
Hey ggc...

I tried a variance of your suggestion, meaning I turned on the "constrain delay compensation" (because it is never active) and recorded a few more tracks with asioguard on & off. Basically the same results with the audio starting about 40ms early. Also tried your midi suggestion...no difference there either.

Again, thanks a lot for the suggestions. One of these days I will try the other audio drivers to see if there is a difference. Man, I have been living with this for so long now that the "moving" of the midi or audio tracks are part of my normal routine. Oh well. ;)

Regards 8-)
PRock Studio

DAW: Cubase Pro 11, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

rasclart
New Member
Posts: 15
Joined: Mon Mar 05, 2012 3:53 am
Contact:

Re: Audio Records Early... Midi is Fine

Post by rasclart »

Prock wrote:
Fri Jul 17, 2015 3:11 pm
ggc wrote:Try opening a new project, top left in the bar with quantise/transport etc- (directly under and between File&Edit above)
-"constrain delay compensation" and turn it off. - ( if it is not visible right click in an empty space and activate visibility)
See how that works for you..(with asioguard off)
Hey ggc...

I tried a variance of your suggestion, meaning I turned on the "constrain delay compensation" (because it is never active) and recorded a few more tracks with asioguard on & off. Basically the same results with the audio starting about 40ms early. Also tried your midi suggestion...no difference there either.

Again, thanks a lot for the suggestions. One of these days I will try the other audio drivers to see if there is a difference. Man, I have been living with this for so long now that the "moving" of the midi or audio tracks are part of my normal routine. Oh well. ;)

Regards 8-)
Hi, I'm having the same problem in cb 10.5, audio records fine in 8.2. Just wondering if you ever got an answer for this, thanks

User avatar
Prock
Grand Senior Member
Posts: 3982
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Audio Records Early... Midi is Fine

Post by Prock »

rasclart wrote:
Tue Feb 04, 2020 12:29 am
Prock wrote:
Fri Jul 17, 2015 3:11 pm
ggc wrote:Try opening a new project, top left in the bar with quantise/transport etc- (directly under and between File&Edit above)
-"constrain delay compensation" and turn it off. - ( if it is not visible right click in an empty space and activate visibility)
See how that works for you..(with asioguard off)
Hey ggc...

I tried a variance of your suggestion, meaning I turned on the "constrain delay compensation" (because it is never active) and recorded a few more tracks with asioguard on & off. Basically the same results with the audio starting about 40ms early. Also tried your midi suggestion...no difference there either.

Again, thanks a lot for the suggestions. One of these days I will try the other audio drivers to see if there is a difference. Man, I have been living with this for so long now that the "moving" of the midi or audio tracks are part of my normal routine. Oh well. ;)

Regards 8-)
Hi, I'm having the same problem in cb 10.5, audio records fine in 8.2. Just wondering if you ever got an answer for this, thanks
Sorry, no answer. I determined that, for me, my audio was recording correctly. It is certain VSTi's that record late. So I have since created templates that have Instrument Tracks (used with certain VSTi, like ezdrummer 4) saved with a -43ms track delay. This works fine and corrects the issue for me.

Regards. 8-)
PRock Studio

DAW: Cubase Pro 11, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

rasclart
New Member
Posts: 15
Joined: Mon Mar 05, 2012 3:53 am
Contact:

Re: Audio Records Early... Midi is Fine

Post by rasclart »

was hoping you wouldn't say that! Just checked CB 8.2 and all is working as it should, CB 10.5.1 is a mess for me, will look into the track delay.
thanks for getting back to me!

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 6 guests