Hint to reduce dropouts

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
User avatar
MovingWaves
Junior Member
Posts: 64
Joined: Tue Jan 04, 2011 10:39 am
Contact:

Hint to reduce dropouts

Post by MovingWaves » Fri May 13, 2016 11:36 am

The Problem
On my system if I move a window or change tracks etc. I would get, and hear, audio dropouts.
These dropouts were really annoying, especially when using looped sections while mixing.

After much research using the internet and Cubase forums I determined a solution for my system. It may help other users so I outline my solution here.

Logically with the power of my graphics card, 2GB of DDR3 GPU memory with fast bandwidth, I felt it had enough power to handle the display needs of Cubase.

As we now have to use the Aero Graphics System to run Cubase 8 the OS requires time to do its Aero thing. Even though we can optimize Aero for maximum performance and appearance I don't think it can use the graphics processor (I may be wrong here)

Cubase, by default, sets its processor priority to "high" (See Windows Task Manager) which seems to be desirable for a DAW. However the Processor Affinity for Cubase is allocated to all CPU predecessors.

On my system I have 8 CPU processors. By changing the Processor Affinity to allow Cubase to only use CPUs 0 to 6 (Uncheck CPU 7) the asio dropout problem completely went away.
It seems that allowing the OS a bit more processing time to its thing really helped.

This solution
I created a short cut to always start Cubase with this affinity.

On Windows.
1) Create a standard short copy on the desktop.
2) Right click and select properties.
3) In the Target: setting add C:\Windows\System32\cmd.exe /c start "Process Monitor" /affinity 7F before the current text.
e.g., C:\Windows\System32\cmd.exe /c start "Process Monitor" /affinity 7F "C:\Program Files\Steinberg\Cubase 8.5\Cubase8.5.exe"
4) Change the Run: setting from "Normal Window" to "Minimized"

Hope this helps :idea:

My Test System
Audio
Behringer FCA1616
Streaming buffer depth = 2000us
ASIO buffer depth = 10.0 ms 480 samples
Graphics card
NVIDIA Quadro K620
Operating System
Windows 7 Ultimate 64-bit SP1
Cubase 8.5
DAW
W10 64Bit-Cubase 10
Intel Core i7 4770K @ 3.50GHz - 32 Gig Ram - 2x238GB ATA OCZHDD's -2048MB DELL U3415W on NVIDIA Quadro K2000
Interface AD/DA
MOTU 828es - (Retired:- Focusrite Saffire PRO 40 - Focusrite OctoPre MkII Dynamic)
Monitoring
Mackie HR624 Studio Monitors
Opal Event Studio Monitors

registered
Junior Member
Posts: 69
Joined: Sun Dec 19, 2010 9:01 pm
Contact:

Re: Hint to reduce dropouts

Post by registered » Sat May 14, 2016 4:12 pm

Thanks! I'm not having this problem, but this type of info is rare and hard to discover via Google. (At least in a DAW context.)
Cubase apparently has some nice workarounds, but little clarity about how to use them, or what they do.
Earle Mankey
Win 10, i7, UAD Apollo, Cubase 9.5.41
MCI 24 track, AMEK Angela console

User avatar
peakae
Grand Senior Member
Posts: 3032
Joined: Sat Jan 05, 2013 8:15 pm
Location: Bedroom
Contact:

Re: Hint to reduce dropouts

Post by peakae » Sun May 15, 2016 10:29 am

In studio one, there is a preferences option to change the CPU affinity permanently within the program.
I wish Cubase had the same option. I have used it in the past when my FireWire driver was hardcoded to use CPU 0
Letting my DAW's run on only CPU 1 to 7 resolved my audio stutter problem in Cubase, studio one and reaper.
When I later changed to a RME Raydat it was not necessary anymore.
Highly system dependent, but worth having a look at the task manager if any core is using a lot more CPU even before starting the DAW.
Cubase Pro 10, Wavelab Elements 9, I7 3770K , win10x64, 16Gb Ram, RME Raydat, Steinberg MR816x, Motu 828mkII, Behringer ADA8200, Yamaha moXF6, Steinberg UR242, Yamaha THR 10, Grace Design m900, CMC TP, CMC CH.

GeoMax
Junior Member
Posts: 74
Joined: Fri Feb 18, 2011 10:47 pm
Contact:

Re: Hint to reduce dropouts

Post by GeoMax » Sun Jun 05, 2016 9:10 pm

I use this too. I pulled down LatencyMon and watched what processes where being naughty. My Nvidia driver likes to park itself on CPU0. I found a few other things to disable that were CPU hogs and not needed.
http://www.resplendence.com/latencymon_using

Here is a good link to figure out the Affinity parameter for those with varying numbers of CPU cores.
http://www.eightforums.com/tutorials/40 ... ndows.html

When my CPU is peaking in cubase, but only using 50% of overall CPU, something other than Cubase is involved.
Using this, I can get much more out of my current rig without the pops and dropouts.
Cubase Pro 10.0.5, Wavelab Pro 9.5
MASTER DAW PC - Windows 10 Pro, i7-6950x (10core), ASUS X99, 128GB Ram, GTX 970, DELL P4317q 43" 4K Monitor
Interfaces: Waves Soundgrid, (2) Digigrid IOXs, X-WSG with Midas M32C and X32 Rack

User avatar
soundpeaks_net
Member
Posts: 380
Joined: Fri Dec 09, 2016 10:14 am
Contact:

Re: Hint to reduce dropouts

Post by soundpeaks_net » Tue Jun 13, 2017 4:44 pm

Hm, is it my issue? https://youtu.be/bpoXBUU3NxM

I need try this too.

AdamWarlock
New Member
Posts: 2
Joined: Wed Aug 12, 2015 3:51 am
Contact:

Re: Hint to reduce dropouts

Post by AdamWarlock » Thu Oct 18, 2018 7:36 pm

Is there something for Mac OS does this same processes??? I have been dealing with dropouts in Cubase for as long as I can remember.
OS 10.13.6 High Sierra - iMac15.1 - Intel i7 4GHz 32 GB - Cubase Pro 9.5 latest - (2) MR816cCSX + G Technology Thunderbolt Drives + UAD Satellites - AMD Radeon R9 M295X. Yamaha Steinberg FW Driver V1.7.5 Boot V1.00 Main V1.10 IEEE1394 V1.02

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 14 guests