How do I properly monitor midi tracks?

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
WillfullyDamned
New Member
Posts: 23
Joined: Fri Jun 08, 2012 1:17 am
Contact:

How do I properly monitor midi tracks?

Post by WillfullyDamned »

Here is my dilemma and I'll try to phrase it the best I can...

I am recording midi into Cubase via my Kronos through USB on channel 1.

When I have record enable/monitor on and the Kronos set as my output on the midi track I run into a phase issue where clearly the signal is being duplicated when I play my keyboard (fyi the midi isn't recording duplicate notes)

This is problematic because I am trying to record/playback without having to keep switching the output of the midi track between "Kronos" to "not connected" or change the midi channel in order to avoid this phase issue.

This is hindering my workflow and I feel that I am just making a stupid error out of ignorance in my signal flow/settings. Any ideas?

User avatar
Konrath
Member
Posts: 235
Joined: Wed Feb 02, 2011 8:53 pm
Contact:

Re: How do I properly monitor midi tracks?

Post by Konrath »

I guess, you have a routing problem with your sound interface, especially its mixer application. But we can't have any idea because you don't tell us anything about your equipment but your Kronos.
"I don't understand why people are afraid of new ideas. I'm afraid of the old ones." - John Cage

Cubase 10.5.20 ( 11.0.0 / Spectralayers 7.0.20 / Sound Forge Pro 14 / Cubase iC Pro / Win 10 20H2 64bit / Tascam US20x20 (Panel 4.0) / Cakewalk 3UMG / Akai MPK88 / Doepfer R2M

misohoza
Member
Posts: 966
Joined: Sun Oct 05, 2014 12:18 am
Contact:

Re: How do I properly monitor midi tracks?

Post by misohoza »

When I have record enable/monitor on and the Kronos set as my output on the midi track I run into a phase issue where clearly the signal is being duplicated when I play my keyboard (fyi the midi isn't recording duplicate notes)
Did you turn the "Local off" on the Kronos?
Win 10 Home, 64 bit, 8 gb ram,
Cubase Pro 10.5, Wavelab Pro 9.5, Halion 6, Dorico 3,
NI Komplete 10 Ultimate, Ozone 7,
UR 44

User avatar
Konrath
Member
Posts: 235
Joined: Wed Feb 02, 2011 8:53 pm
Contact:

Re: How do I properly monitor midi tracks?

Post by Konrath »

A chorus like sound or phase issue is created often by routing the input of the instrument in the mixer application of your Hardware to a stereo out while monitoring via your daw. Check for this because Cubase has its own routing. When using cubase I always switch my mixing application off to give cubase complete control for routing.
The local on is only for activating the midi control for the Korg as it is on my MicroX. That shouldn't have influence on the sound.
"I don't understand why people are afraid of new ideas. I'm afraid of the old ones." - John Cage

Cubase 10.5.20 ( 11.0.0 / Spectralayers 7.0.20 / Sound Forge Pro 14 / Cubase iC Pro / Win 10 20H2 64bit / Tascam US20x20 (Panel 4.0) / Cakewalk 3UMG / Akai MPK88 / Doepfer R2M

User avatar
Parrotspain
Member
Posts: 654
Joined: Fri Jan 28, 2011 6:28 pm
Contact:

Re: How do I properly monitor midi tracks?

Post by Parrotspain »

I don't think this is an audio / soundcard issue - it's likely to be MIDI signals being duplicated

Have you tried setting MIDI Thru to inactive? In MIDI Prefs.

I think you are triggering the same sound on Kronos from both internal keyboard and via computer. Setting Local OFF on Kronos would sort it, but then make your Kronos mute when not routed via Cubase. So the above fix should might batter for you.
Cubase Pro 11.0.0

Win10 Home 20H2. Biostar A960D+ AMD FX8350. 32Gb.Ram, SSDs. UR22mk2 / UR424
Softube Console 1 Mk2: SSL4000e, BCA, ACA, Faderport (classic).

User avatar
Konrath
Member
Posts: 235
Joined: Wed Feb 02, 2011 8:53 pm
Contact:

Re: How do I properly monitor midi tracks?

Post by Konrath »

Mh. Probably.
But this will be easy to check.
If WillfullyDammned geht this sound while he is recordiing without hitting a key then it is an issue with audio routing. When he get the described behaviour only while playing the keys than it should be a midi thing.
"I don't understand why people are afraid of new ideas. I'm afraid of the old ones." - John Cage

Cubase 10.5.20 ( 11.0.0 / Spectralayers 7.0.20 / Sound Forge Pro 14 / Cubase iC Pro / Win 10 20H2 64bit / Tascam US20x20 (Panel 4.0) / Cakewalk 3UMG / Akai MPK88 / Doepfer R2M

Svenne
Member
Posts: 725
Joined: Sun Sep 25, 2011 10:29 am

Re: How do I properly monitor midi tracks?

Post by Svenne »

Konrath wrote:The local on is only for activating the midi control for the Korg as it is on my MicroX. That shouldn't have influence on the sound.
Of cause it does. Think about it. With Local On engaged, the sound generating circuitry receives two note-on instructions for every note your press; one from the keyboard and another that has gone through your computer. The last one hast taken the long way around and arrives a bit later then the first one. This latency is the cause of phasing you hear. It also uses twice as many voices per key, thereby halving your available polyphony.

This problem was the reason why local on/off was invented, some 30 years ago, in the first place.

Set your Kronos to "Local Off", while you're recording, and this will solve your problem.

Another option is to deactivate "MIDI Thru Active" in Preferences/MIDI. This will also prevent duplicate key-on messages. I prefer the Local-Off alternative, but I guess that's a matter of taste.
Cubase Pro 8.5.20 + IC Pro, WaveLab Elements 9.0.30, Mac Pro 2.8GHz 8-core 8GB, 10.11.6 (El Capitan), MR 816X, Avid Control/Mix, iPad Air (128GB), Cubasis 2.0, iTrack Dock.

WillfullyDamned
New Member
Posts: 23
Joined: Fri Jun 08, 2012 1:17 am
Contact:

Re: How do I properly monitor midi tracks?

Post by WillfullyDamned »

It turns out, Local Control being activated was the source of my problem. Thanks for the help everyone. I thought I would have to have local control on to hear myself but I was mistaken.

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests