MI4, drivers & Win7 - Does not work!

For users of legacy Steinberg hardware
Post Reply
mplaksant
New Member
Posts: 3
Joined: Wed Jun 29, 2016 1:49 pm
Contact:

MI4, drivers & Win7 - Does not work!

Post by mplaksant » Wed Jun 29, 2016 1:58 pm

I bought a used MI4 card with Cubase System 4 (CDs for Cubase SL 2 and SX). However I can not install properly the sound card. I download from Steinberg site the latest drivers for Vista 64bit, installing goes great, however in Device Manager it shows that the card can not be identified by the drivers although the USB part is installed properly, so no software identifies the card. It seems like the drivers are not installed as it should. I searched on the internet and also here in the forum, I tried anything I found, but no result. Please, I need your help.
Thanks a lot

mplaksant
New Member
Posts: 3
Joined: Wed Jun 29, 2016 1:49 pm
Contact:

Re: MI4, drivers & Win7 - Does not work!

Post by mplaksant » Thu Jun 30, 2016 6:03 pm

does anybody knows please?

jwka
New Member
Posts: 3
Joined: Mon Feb 08, 2016 9:46 am
Contact:

Re: MI4, drivers & Win7 - Does not work!

Post by jwka » Thu Aug 11, 2016 9:16 pm

would be interested also ... same issues with external MI4 USB interface. Install in Win7 64 bit.

Wwooley
New Member
Posts: 1
Joined: Thu Oct 12, 2017 2:42 pm
Contact:

Re: MI4, drivers & Win7 - Does not work!

Post by Wwooley » Thu Oct 12, 2017 2:58 pm

I've been wanting a small usb interface to take to school with me.
I just picked up an MI4 at the local pawn shop.
When I went on the website to register my interface it's not in the list of products.
I googled the model number and found a page with drivers for Win 7 but I can see people have had some issues trying the 64 bit vista drivers.
Has anyone here got this working?
How did you wind up configuring it?
This is my first Steinberg product.

Post Reply

Return to “Legacy Steinberg Hardware”

Who is online

Users browsing this forum: No registered users and 0 guests