Can’t get sound on playback, or other audio problem? Check out this video.

Discussions about our next-generation scoring application, Dorico.
Post Reply
User avatar
Daniel at Steinberg
Moderator
Posts: 12103
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Can’t get sound on playback, or other audio problem? Check out this video.

Post by Daniel at Steinberg » Sat Mar 17, 2018 11:51 am

Anthony and Ulf have worked together to produce a very detailed video that walks through all of the common problems that Dorico users may experience with playback, covering things like ensuring HALion Sonic SE 2 and HALion Symphonic Orchestra is correctly installed, cleaning the MediaBay cache so you can load sounds into HSSE2, solving problems with other applications not being able to make sound when Dorico is running, and much more.

If you have any kind of audio or playback problem with Dorico, this is a great place to start:

Watch on YouTube

Derrek
Senior Member
Posts: 2200
Joined: Sun Aug 07, 2016 6:23 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by Derrek » Sat Mar 17, 2018 5:06 pm

Kudos (as usual) to Anthony and Ulf!
Dorico 2.2.10, Finale (v26), GPO, JABB3, GWI, NotePerformer 3, CuBase newbie
Windows 10 (also Mac High Sierra as alternate)
US English Keyboard

pizzarco
New Member
Posts: 15
Joined: Sun Feb 25, 2018 10:20 am
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by pizzarco » Sun Mar 18, 2018 1:57 pm

Thanks, very useful, informative and easy to follow.

User avatar
ShikiSuen
Member
Posts: 341
Joined: Thu Mar 08, 2012 2:47 am
Location: Edogawa, Tōkyō, Japan
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by ShikiSuen » Fri Mar 23, 2018 6:25 pm

Supplementals to readers:

1. The method provided in the video regarding how to clean HALion Sonic SE cache actually cleans the cache of the VSTAudioApp. To my experience dealing with my self-made HALion Sonic SE patches, I sometimes have to refresh the programs list in HALion Sonic SE twice. I personally suggest upgrading HALion Sonic SE to the free HALion Sonic SE 3 (its activation code is freely retrievable from Steinberg, or you could use it directly if having Cubase 9.5 or later versions installed) due to its HALion Library Manager app which allows you to manually remove-and-reinstall a HALion Library. Dorico relies on two libraries for its default playback: HALion Sonic Artist Library (for the YAMAHA S90ES Piano program) and the HALion Symphonic Orchestra. Both of their installations could be handled in the HALion Library Manager.

2. In case of using Dorico, you may want to disable all audio inputs inside the Generic Low-Latency ASIO Driver Settings / macOS ASIO Device Control Panel (accessible through any of Steinberg audio apps on mac). Dorico is not an audio recording software, hence the uselessness of enabling audio input support. Disabling such support could reduce the workload of ASIO driver.

Note: One may wonder why ASIO on mac, and the reason is that Steinberg uses CoreAudio2ASIO converter to utilize CoreAudio on macOS. Similarly, Generic Low-Latency ASIO Driver is a WASAPI2ASIO converter written by Steinberg, according to Palm Walmsley.

3. For macOS users, please ALWAYS uncheck the Device Attenuation "to 0dB" settings UNLESS your audio interface does not support software audio volume tuning through macOS System Preferences. This is to make sure you won't get hearing loss from sudden loud playback. This issue (or "design") exists prior to when Dorico developers get acquired by Steinberg, and Dorico developers may not be the best people to explain why CoreAudio2ASIO converter behaves like this by default.

4. There are other software-based WASAPI2ASIO converters which could be workarounds if Generic Low-Latency ASIO Driver does not work. However, to my experience, such drivers' stability depends on the actual audio chipset used on your computer. For example, the MacBook Pro late-2016 and mid-2017 utilizes a simplified Cirrus Logic audio chipset which has only 48000Hz available on BootCamp-installed Windows (and soft-converted 44100Hz & 96000Hz on macOS). You may only want to use 48000Hz on these Mac models to avoid CPU usages caused by unnecessary sample rate conversions.

5. If you are a mac user and are looking for an external audio interface for Dorico use only, I suggest choosing a USB class-compliant audio interface. If a USB audio interface is not class-compliant, it may cause issues when your macOS installs a system update.

# EOF.
// My first name is Shiki.

[DAC + Monitor] laptop built-in DAC & Native Instruments Komplete Audio 2, ATH-M70X;
[DAW + OS] PreSonus Studio One 4 on macOS 10.14 Mojave and macOS 10.15 Catalina;
[Notation Tool] Steinberg Dorico Pro 2;
[Laptop] MacBook Pro 15-inch mid-2017 CTO, Core-i7 Kaby Lake (Quad-Core 2.8GHz), 16GB RAM.
[Desktop] Mac Pro Cylinder late-2013, Xeon E5-1650 (Hexacore 3.5GHz), 32GB RAM.

moonboy
New Member
Posts: 5
Joined: Wed Apr 04, 2018 12:59 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by moonboy » Sat Apr 07, 2018 8:30 pm

Thanks for this!!

mducharme
Junior Member
Posts: 88
Joined: Thu Apr 21, 2011 1:00 am
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by mducharme » Wed Jun 06, 2018 3:21 am

I run Dorico 2 on a Macbook Pro 2016 bootcamp and actually discovered that it doesn't even see the audio output at all unless Dorico is set to use 48 kHz. No sound at all at 44.1, need to go to 48 to get any sound.

Dich
Junior Member
Posts: 88
Joined: Tue Oct 25, 2016 8:07 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by Dich » Wed Jun 27, 2018 7:24 pm

Thanks to Anthony for this fine video. It presented the solution after a reinstall of Windows 10 and all programs. Everything worked, only there was no playback sound in Dorico. An uncheck in an ASIO-box and I could see my sound-USA-Card UR22mkII. Anthony is a very good and structured teacher for a fumbler.

asbefore
Member
Posts: 244
Joined: Fri Oct 21, 2016 5:45 am
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by asbefore » Wed Aug 15, 2018 7:27 pm

mducharme wrote:
Wed Jun 06, 2018 3:21 am
I run Dorico 2 on a Macbook Pro 2016 bootcamp and actually discovered that it doesn't even see the audio output at all unless Dorico is set to use 48 kHz. No sound at all at 44.1, need to go to 48 to get any sound.
I'm running Dorico 1 on an older Macbook and discovered the same problem / solution -- once I adjusted the audio settings to use 48khz, everything started working again. What a wonderful thing - thanks for the solution!

bakadesh1
New Member
Posts: 12
Joined: Mon Jun 16, 2014 5:11 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by bakadesh1 » Mon Aug 20, 2018 12:23 am

And of course, if you've just updated, be sure to download and install more than just the update to Dorico; it's perhaps best to go through the Steinberg Download Assistant to be sure you've updated to the latest versions of HALion Sonic SE 3, etc., as well.
--------------------------------------------------
David C. Adams
Composer
davidcarltonadams.com
Co-director, Fast Forward Austin
fastforwardaustin.com

User avatar
marco_polo
New Member
Posts: 35
Joined: Thu Aug 17, 2017 4:08 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by marco_polo » Fri Aug 24, 2018 9:01 pm

I had a playback problem after importing old pieces via the xml-import: there was audio (from any selected sound source) when entering notes and editing music, but no playback when hitting playback proper from Play Mode.
I tried all known ways to get that worked around and it took me HOURS, but to no avail. Eventually I gave up, set up a new score template and copied the music stave by stave from the old file into the new one, and it finally all worked.
It is moments like theres that temporarily make me resent Dorico, because I've never had such kind of trouble with Sibelius, EVER.
I find myself scanning the forum regularly and it all just still costs too much time. But I'm sticking with it…

User avatar
dankreider
Grand Senior Member
Posts: 3413
Joined: Thu Jun 28, 2018 3:45 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by dankreider » Fri Aug 24, 2018 10:46 pm

marco_polo wrote:
Fri Aug 24, 2018 9:01 pm
I've never had such kind of trouble with Sibelius, EVER.
To clarify: you’ve never had a problem importing XML into Sibelius?

It’s well-known that, when an XML import into Dorico goes wrong, the culprit is typically XML. Not to say Dorico is above improvement (this forum is proof of that!), but XML is simply not ideal. People who use it (like me) do so only because they have no choice.
Dan Kreider

Orchestration, transcription, engraving
Dorico training for individuals and teams
www.dankreider.com
---
Windows 10

User avatar
marco_polo
New Member
Posts: 35
Joined: Thu Aug 17, 2017 4:08 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by marco_polo » Sat Aug 25, 2018 9:59 am

I've actually never had substantial problems in importing xml into Sibelius. But then again, the scores I am transferring over from Sib into Dorico are much more complicated that most of the stuff I used to import into Sib in the first place,...
I agree that XML is not the best means of transfer possible, but at least better that bare MIDI files.

rhallsw
New Member
Posts: 10
Joined: Wed Oct 10, 2018 6:44 pm
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by rhallsw » Thu Oct 11, 2018 1:02 am

The video is superb and I did get sound on playback with Dorico 2.1 (cross-grade from Sibelius on Windows), but with the following caveat. I have two playback drivers: i) Speakers (USB DAC but 24-bit sound only) and ii) JRiver music player input (used for routing external music). I kept the Dorico ASIO driver and set the USB driver to 44.1 kHz as directed. In Device Control Panel, if the "Allow ASIO ..." box was checked, only the JRiver driver appeared, while if the "Allow ASIO ..." box was not checked, only the Speakers driver appeared! I selected "unchecked" to get the desired Speakers driver and restarted Dorico. I did not get sound, and was concerned about incompatibility with the 16-bit ASIO.

After much playing around, I found that if I toggled the "Allow ASIO ..." box on and off, I got sound on Play. However, I had to repeat this toggle operation on each new project to get sound. All of the example projects played correctly, despite the dubious driver behavior above. I did not try disabling the JRiver driver, since I do use it and there may be a nicer option. Anyway, I have many tutorials to view and they are much nicer when playback sound is present.

Greetings Daniel; I got help from you several times when you were "Daniel at Sibelius". As a retired software developer, I can appreciate what you and your colleagues have achieved with Dorico.

User avatar
Daniel at Steinberg
Moderator
Posts: 12103
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Can’t get sound on playback, or other audio problem? Check out this video.

Post by Daniel at Steinberg » Fri Nov 02, 2018 1:12 pm

I'm unsticking this thread now: the information about this video is now consolidated into the general troubleshooting information provided in this new thread.

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: Stephen Taylor and 4 guests